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INTRODUCTION
What is ExchangeIt!?
ExchangeIt! provides collaboration services running as a fully integrated service on the
Net Integrator server. ExchangeIt! works seamlessly with Microsoft Outlook to help you
create, organize and share information quickly and easily.
Thanks to its complete integration into the Net Integrator operating system (“NIOS”),
ExchangeIt! is able to take full advantage of advanced NIOS technologies such as
NetIntelligence, idb, and System ER. This makes ExchangeIt! an easy collaboration
system to set up, maintain and backup.

Outlook + ExchangeIt! - What do they do?
In order for Outlook to work with ExchangeIt! a small Outlook plug-in, developed by Net
Integration and available free of charge, needs to be installed on every workstation that
requires ExchangeIt! functionality. (ExchangeIt! licenses is handled on the server).
When you use the Microsoft Outlook mail client with ExchangeIt!, the following features
are added to its functionality:
! Schedule Sharing: Personal Outlook calendars can be shared with other
ExchangeIt! users.
! Group Schedules: Shared calendars can be created for multiple users (or Net
Integrator “teams”); each team member will have access to the shared calendar.
These shared calendars are the equivalent of shared public resources, and can
relate to people or to conference rooms and other meeting resources such as video
projectors.
! Meeting Invitations: Users can schedule meetings with other users and also book
conference rooms and other meeting resources. Invite users to meetings; when
they accept, the event appears in their calendar. View the free/busy times for
meeting invitees and resources when scheduling a meeting.
! Contact List Sharing: Share personal contact lists with other users.
! Group Contact Lists: Maintain shared contact lists that everyone can access and
contribute to.
! Task List Sharing: Share personal task lists with other users.
! Group Task Lists: Maintain shared task lists that all users or team members can
contribute to.
! Journal Sharing: Share personal Outlook journals with other users.
! Notes Sharing: Share Outlook notes with other users.
! Group Notes Sharing: Maintain shared notes folders that all users or team
members can access and contribute to.
! Access Control Lists and Shared Folder Permissions: Give other users or
teams permission to view, edit or change calendars, contact lists, notes, journals
and task lists. Each user or team can have “Read,” “Read/Write” or
“Read/Write/Admin” rights to a folder.
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!

Outlook Synchronization: Information contained within Outlook personal
folders (with the exception of deleted items and email messages) is uploaded and
synchronized with the ExchangeIt! database. This yields the following
advantages:
! Backup – if a workstation’s Outlook data is lost, it can easily be resynchronized from the server. The ExchangeIt! database is also backed up by
the idb backup system on the Net Integrator server.
! RoamingAccess – Outlook will have your synchronized personal folders even
if you are on a different computer.
! WebAccess – ExchangeIt! data is synchronized with the Net Integrator.
WebMail web-based mail and collaboration interface. This allows easy access
to a user’s Outlook data from any browser.
NOTE: This feature is NOT available in the ExchangeIt! 1.0 release, but will
be available in a future release.

NOTE: ExchangeIt! requires Microsoft Outlook 2000 or Microsoft Outlook 2002 running on a
Windows 2000 or Windows XP platform.

Purpose Of This Manual
This manual will focus on the use of Outlook 2000 and Outlook 2002 with ExchangeIt!
Please refer to your Microsoft Outlook manual for the Outlook specific functionalities not
covered in this manual.
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INSTALLATION
Installing ExchangeIt!
See your System Administrator or Net Integrator representative for an ExchangeIt! client.

SETTING UP YOUR OUTLOOK CLIENT
Please Note: In order to use ExchangeIt!, you must have a user account on the Net
Integrator.
Software Requirements: ExchangeIt! requires Microsoft Outlook 2000 or Microsoft
Outlook 2002 running on a Windows 2000 or Windows XP platform. ExchangeIt! is not
compatible with any version of Microsoft Outlook Express, Microsoft Outlook 98 or
other mail packages.

Configuring Microsoft Outlook 2000
Please Note: For Microsoft Outlook 2002, see “Configuring Microsoft Outlook 2002”
below.
Please Note: You need to have Microsoft's Web Publishing Wizard installed in order for
the free/busy services to work with Outlook 2000 on Windows 2000. If this has not
already been installed on your computer you can download the installation file from:
http://www.microsoft.com/downloads/release.asp?ReleaseID=22658

Configuring E-mail
If you are already using Outlook 2000 for your e-mail in Internet mode, select Tools >
Accounts. Click on Add > Mail. The Internet Connection Wizard screen appears.
Jump to Step five (5).
If this is your first time using Outlook 2000, start at step one (1).
1. Open Microsoft Outlook 2000.
Please Note: Corporate Mode Microsoft Outlook is not supported. Please go to
Tools > Options > Mail Delivery and click on Reconfigure Mail Support to
reconfigure Outlook to Internet Only mode. [If you are unsure how to accomplish
this, please refer to your Office 2000 documentation].
2. The User Name screen appears.
3. Enter your Name and Initials. Click the OK button.
4. The Internet Connection Wizard screen appears.
5. Enter your Display name (this is the name that will appear on your outgoing email). Click the Next button.
6. Enter your E-mail Address. Click the Next button.
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7. The next screen will ask, “My incoming e-mail server is a ____ server.” Select
IMAP from the server drop-down list.

Please Note: We recommend that you use an IMAP e-mail server. However,
ExchangeIt! will work with POP3 e-mail servers, but you will lose your ability to
have your mail remotely accessible.
8. Enter the name of your incoming mail server (this is the name of the Net
Integrator).
9. Enter the name of your outgoing mail server (this is the name of the Net
Integrator).
10. Click the Next button.
11. Enter your Account name and Password (password is optional).
Please Note: Ensure that the Log on Secure Password Authentication (SPA) is not
checked.

12. Click the Next button.
13. Select which method you want to use to connect to the Internet (local area
network).
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14. Click the Next button.
15. Click the Finish button.

Directory Services Setup
1.
2.
3.
4.

In Outlook, select Tools > Accounts.
Select Add > Directory Services.
The Internet Connection Wizard screen appears.
Enter your Internet directory (LDAP) server name (this is the name of the Net
Integrator). Click Next.

5. It will ask, “Do you want to check Addresses using this directory service?” Select
Yes.

6.
7.
8.
9.

Click the Next button.
Click the Finish button.
Click the Close button.
Close Outlook.
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Configuring Microsoft Outlook 2002
Please Note: For Microsoft Outlook 2000, see “Configuring Outlook 2000” above.

Configuring E-mail
If you are already using Outlook 2002, select Tools > Accounts, then click on Add >
Mail. The Internet Connection Wizard screen appears. Jump to Step five (5).
If this is your first time using Outlook 2002, start at step one (1).
1.
2.
3.
4.
5.
6.
7.

Open Microsoft Outlook 2002.
The Outlook 2002 Startup screen appears.
Click the Next button.
The Account Configuration screen appears.
Click the Yes button.
Click the Next button.
The Email Accounts screen appears asking you to select your e-mail server type.
Select IMAP.

Please Note: We recommend that you use an IMAP e-mail server. However,
ExchangeIt! will work with POP3 e-mail servers.
8. Click Next.
9. Enter your User Information, Server Information and Logon Information.
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Please Note: Ensure that the Log on Secure Password Authentication (SPA) is not
checked.
10. Click the Next button.
11. Click the Finish button.
12. The User Name screen appears. Enter your Name and Initials. Click the OK
button.
Please Note: The User Name screen only appears if it your first time using
Outlook.

Directory Services Setup
1. From Outlook, select Tools > Email Accounts.
2. The Email Accounts screen appears.

3. Under Directory, choose Add a new directory or address book.
4. Click the Next button.
5. Select Internet Directory Service (LDAP).
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6. Click the Next button.
7. Enter the Server name.

8. Click the Next button.
9. The Add Email Account screen appears asking if it is okay to exit Outlook. Click
the OK button.
10. Click the Finish button.

Installing Client Plug-in
Please Note: You must be logged in as the Administrator to install the ExchangeIt! plugin. Installing the plug-in using a user account may not install the plug-in properly.
Please Note: You must configure Outlook before installing the ExchangeIt! plug-in.
1. Go to where you placed the ExchangeIt! plug-in.
2. Double-click the ExchangeIt! plug-in.
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3. The ExchangeIt! Plug-in for Microsoft Outlook Setup: License Agreement
window displays.
4. Click the I Agree button to accept license.
5. The ExchangeIt! Plug-in for Microsoft Outlook Setup: Installation Folder
window displays.
6. Click the Install button to install the ExchangeIt! plug-in in the default
destination, or select a different folder by using the Browse button then click on
the Install button.
7. Once installation is complete, click the Close button.

Configure Outlook to use ExchangeIt!
1. Open Outlook.
2. The ExchangeIt! Login window displays:
3. Select the Message Store you wish to have synchronized. The default store is
“Personal Folders.”
4. Enter the name of your Net Integrator Server. The default name is calendar.
5. Enter your User name and Password.
6. Click the OK button.

To Enable Synchronization
1. From the Outlook Tools menu, select Options.
2. Click on the ExchangeIt! tab.
3. Ensure that the Enable ExchangeIt! periodic synchronization is checked.
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4. Click on the OK button.
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EXCHANGEIT OUTLOOK FEATURES
The Folder List
Folders in Outlook can help you manage your mail by filing messages based on certain
criteria that are at your discretion.
The folders within Outlook are used for storing items that you create in the various
Outlook modules: e-mail messages, calendar items, contact names, tasks and sub-folders.
Each module has its own folder that you can see in the Folder List. The Folder List is
simply a list of the folders accessible from Outlook (see Figure 1).
For more details on these folders, see the next section, “Folders Accessible from
Outlook”.

Figure 1

The Folder List in Outlook displays all of the folders that are located in your ExchangeIt!
server account, Public Folders, as well as those located in your Personal Folders.
To see the Folder List select View from the Outlook toolbar and click on Folder List.
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Folders Accessible From Outlook
The Folder List in Outlook will allow you to see all of the folders that Outlook can
access. These folders can be stored on the ExchangeIt! server, your hard drive or a
network share.
Outlook can access any folders and subfolders in your account on the ExchangeIt! server,
as well as Public Folders. Folders not on the ExchangeIt! server that Outlook can access
are your Personal Folders.

IMAP Mail Folder
The folder entitled Inbox under your server name (see Figure 2) in the Folder List view is
the root folder in your account on the ExchangeIt! server.
IMPORTANT: When using Outlook with IMAP, your e-mail will be delivered to
the Inbox under your server name, and not the Inbox under your Personal Folders.

Figure 2

Personal Folders
The Calendar, Contacts, Deleted Items, Drafts, Inbox, Journal, Notes, Outbox, Sent Items
and Tasks folders in the “Outlook today - [Personal Folder]” or “Personal Folder”
folder are all subfolders of your Mailbox. (Note: you can create your own subfolders that
will be stored on the ExchangeIt! server in your account – see Creating Folders).
ExchangeIt! enables you to share any of your Calendar, Contacts, Tasks, Notes or Journal
files in your Personal Folders with other user(s). These shared folders are only open to
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those who are given permission by the creator or the "owner" of the folder. (By default,
no one but you has permission to access your Personal Folders).

Public Folders
Public folders (see Figure 3) are stored on the ExchangeIt! server and may not be
particular to anyone’s account. They serve as a location on the ExchangeIt! server for the
files shared with you by other users and for files shared by members of a Net Integrator
“team account.” In Figure 3 for example, a Contacts list for office staff (“Staff List”) was
created in the team access folder entitled “office” under the Public Folders so that
everyone in the office had permission to look at the contents of the folder.

Figure 3

Creating Folders
Personal Folders
You can create new folders in your Personal Folders to share with other users.
1. Right click on Personal Folders (see Figure 4).
2. Enter a Name for the new folder.
3. Select the type of folder from the Folder Contains drop-down list (you can select
Appointment, Contact, Journal, Mail, Note or Task Items). (Figure 4b).
4. Click OK.
NOTE: for information on sharing the new folder, see Giving Someone Else Access
to Your Folders.
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Figure 4b

Figure 5

Public Folders
You can create new folders in the Public Folders under team accounts.
1. Right click on the team account folder under Public Folders (see Figure 5).
2. Enter a Name for the new folder.
3. Select the type of folder from the Folder Contains drop-down list (you can select
Appointment, Contact, Journal, Mail, Note or Task Items). (Figure 5b).
4. Click OK.
NOTE: for information on sharing the new folder, see Giving Someone Else Access
to Your Folders.

Figure 6b

Figure 7
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Using your ExchangeIt! Calendar
Calendar
The calendar folder allows you to keep track of your daily schedule as well as schedule
meetings with others. Figure 6 is a screenshot of a typical calendar in daily view. This
view allows you to see your schedule for a particular day, along with your Task pad. As
you can see, you can create meetings and appointments with the Calendar folder.

Figure 8

Create a Meeting Request Using Free/Busy
Please Note: You need to have Microsoft's Web Publishing Wizard installed in order for
the free/busy services to work with Outlook 2000 on Windows 2000. If this has not
already been installed on your computer you can download the installation file from:
http://www.microsoft.com/downloads/release.asp?ReleaseID=22658
1. Click on the Calendar folder from the Folder List.
2. On the monthly calendar, double-click on the date on which the meeting is to
occur.
3. An Appointment Window will appear (see Figure 7).
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Figure 9

4. Enter the meeting date, start and end times in the bottom section. In the Subject
field, enter the subject of the meeting. In the Location field, type the location of
the meeting.
5. If desired, type additional information about the meeting in the text section.
Attachments can be added in this field.
6. Click on the Attendee Availability tab.
7. Click on the Invite Others… button. Select the names of individuals who should
attend the meeting.
NOTE: Names can be put in the Required or Optional attendee boxes.
8. Click OK when finished.
9. On the Attendee Availability screen, the attendees are listed on the left and their
availability is shown in colored lines on the right. In Figure 8, ‘AnyUser1’ is free
to attend the meeting at 11:00, but ‘AnyUser2’ is busy (blue) from 10:00 to 10:30.
NOTE: This is the only information that others will see on your calendar.
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Figure 10

10. At this point, you can change the meeting date, start or end time depending on
attendee availability.
NOTE: The AutoPick button to the left of the meeting times can be used to let
Outlook select the next available time that all of the attendees have a free slot
with enough time to schedule your meeting.
11. After completing the meeting request, click the Send button.
12. The meeting request is then e-mailed to all invited attendees. Invited attendees
have the option of Accepting, Declining, or Tentatively Accepting the meeting
invitation.

Receiving and Responding to a Meeting Request
Meeting requests are e-mailed to you from the requester. To reply to the meeting request:
1. Click the Reply button
2. Enter your response to the individual. You can choose to either Accept, Decline,
or Tentatively Accept the meeting invitation.
3. Check the Send the Response Now option and click OK.
Meetings that are accepted are automatically entered onto an attendee’s calendar.
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Booking Resources
Outlook can be used for booking all kinds of resources, such
as meeting rooms, projectors or whatever resources needs to
be shared in your organization.
Simply create a new shared calendar folder under Public
Folders and name it as the resource (i.e. Boardroom). In this
calendar, you can view the resource’s availability and reserve
the resource for meetings or other events, thereby eliminating
overlapping appointments. You can also “invite” this
resource when creating a Meeting Request and the meeting
will be entered into the resource’s calendar.
NOTE: Someone must “own” the resource calendar in order
to accept meeting requests; otherwise, the meeting will not
be entered into the resource’s calendar. The better
alternative is to make the meeting request from the resource’s
calendar. This will automatically have the booking appear in
the calendar of the resource.

Viewing Someone Else's Folders
In order to view someone else’s folder that they have shared
to you (i.e. calendar), the person must give you at least readonly permission. After they have given you permission, you
will be able to see the folder and its contents. The folder will
appear under Public Folders under the username of the
person sharing the folder to you (Figure 9).

Figure 11

Giving Someone Else Access to Your Folders
To give someone permission to access your calendar in Outlook:
a. Right-click on the folder you wish to share in your Folder List.
b. Select the Properties option from the pop-up menu that will appear.
c. When the Properties dialogue appears, select the ExchangeIt! Permissions tab.
(You will now see the screen in Figure 10. This screen will show you the list of
users and teams who are already authorized to access your calendar and their level
of Permission).
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Figure 12

d. Click on the Add button. This will bring up the list of users and teams on your
ExchangeIt! server (Figure 11).

Figure 13

e. Select the user or team to whom you wish to give access this folder from the
Choose user drop-down menu and click OK. You will be brought back to the
screen shown in Figure 10.
f. Click on the user or team that you’ve just added (make sure that the user or team
is highlighted) and then assign them a Permission level from the Permission level
drop-down list.
g. Click Apply.
h. Click OK.
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To modify a user’s permissions:
1. Right-click on the folder.
2. Select the Properties option from the pop-up menu that will appear.
3. When the Properties dialogue appears, select the ExchangeIt! Permissions tab.
(You will now see the screen in Figure 10. This screen will show you the list of
people who are already authorized to access your calendar and their level of
permission).
4. Select the user or team that you want to change Permission level (make sure that
the user or team is highlighted) and then assign them their new Permission level
from the Permission level drop-down list. (Figure 12).

Figure 14

5. Click Apply.
6. Click OK.
To delete a user’s permissions:
1. Right-click on the Calendar folder in your Folder List.
2. Select the Properties option from the pop-up menu that will appear.
3. When the Properties dialogue appears, select the ExchangeIt! Permissions tab.
(You will now see the screen in Figure 10. This screen will show you the list of
users and teams who are already authorized to access your calendar and their level
of permission).
4. Select the user or team that you want to delete (make sure that the user or team
name is highlighted).
5. Click on the Remove button.
6. Click Apply.
7. Click OK.
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EXCHANGEIT! UNBOUND
This section of the guide is intended to give users and administrators additional insight
into how ExchangeIt! and the Outlook plug-in work to allow for your items to be
synchronized.
The Outlook plug-in client is required in order for Outlook to synchronize folders
properly with the ExchangeIt! server. The plug-in enhances Outlook’s native capabilities
by communicating with the ExchangeIt! server to send and receive data corresponding to
the folders and their contents based upon Access Control Lists (ACL). The ACL is used
between the Outlook plug-in and the ExchangeIt! server to properly share the folders and
their contents to other users.
It is probably best to understand the behaviour of the plug-in and how it interacts with
Outlook to accomplish these tasks to allow you to best take advantage of ExchangeIt!’s
capabilities.

Understanding the installation process
Installation of the plug-in is a straightforward process. However, it is recommended that
the plug-in be installed using an administrative account because many workstations are
deployed such that regular users are restricted from installing / uninstalling software.
To allow for multiple users to work on the same workstation, the plug-in creates separate
profiles for each user based upon their Windows login. Once the plug-in installation has
occurred, each time a new user logs onto Windows and opens Outlook (but has not
previously configured the ExchangeIt! client) they will be asked to configure the client.
All the settings that are entered during this first time login may be later modified by
selecting the Tools Menu of Outlook, then selecting Options. This will pop up a dialog
box that has an ExchangeIt! tab. Selecting this tab will show the user the ExchangeIt!
settings and allow the user to modify them.
There are 5 settings fields:
a. Message Store
b. Server
c. User name
d. Password
e. Enable ExchangeIt! periodic synchronization (only appears if selected from the
Outlook Tools -> ExchangeIt! dialog box)
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Message Store
Outlook is capable of using multiple message stores. For most users, they will only have
one open and available. The default Outlook message store is called “Personal Folders.”
Some of the more advanced Outlook users may have multiple message stores. This field
allows them to select the message stores that the ExchangeIt! plug-in is able to detect in
Outlook based upon availability of folders that it can share such as Calendar and Tasks.
For almost all users, selecting Personal Folders is best. Please refer to Microsoft
Outlook’s documentation for further information on the use and setup of message stores.
The selection of the message store tells the plug-in that this is the message store for
which the user will be synchronizing to the ExchangeIt! server.
Server
This field selects the ExchangeIt! server for which you wish to communicate with for
synchronization. The default name is “calendar.” This is a private DNS entry set by the
Net Integrator when ExchangeIt! is enabled. In most installation cases, this default name
will be sufficient. However, if the workstation is not receiving its DNS from the Net
Integrator running ExchangeIt!, the server name will need to be modified to the name
being resolved by the local DNS server. Using the ExchangeIt! server’s IP address will
also work, but if the local IP address of the server is dynamic, it may pose problems later
if the IP address changes.
User name and password
The user needs to enter their username and password. This needs to be a valid account on
the Net Integrator hosting the ExchangeIt! server. Although it is possible to modify the
username after the initial installation, it is highly recommend that you don’t attempt to do
so. If you wish to switch usernames, it is best to go through an uninstall and reinstall
process rather than simply switching usernames, as many folders will be obsolete and
other folders with appear with confusing results to Outlook.
Enable ExchangeIt! period synchronization
By default the periodic synchronization is enabled. Disabling this option will prevent the
plug-in from communicating with the ExchangeIt! server. For the times that you may
wish to disable the synchronization (i.e. working off-line), disabling this option will stop
messages that may appear warning you that it is unable to communicate with the
ExchangeIt! server.
Additionally, you will want to have this option disabled for users that you don’t wish to
use ExchangeIt!. Disabling this option will prevent the plug-in from requesting the user
information each time the user opens Outlook (if they aren’t utilizing ExchangeIt!), since
clicking cancel at the request only disables the ExchangeIt! plug-in during that particular
Outlook session.
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Access Control List and Permissions (ACL)
The ExchangeIt! server provides access to items based upon permissions set on a folderby-folder basis. In other words, the permissions of all items contained within a folder are
based upon the permissions set on the folder itself.
The following describes the 3 permission levels and what they imply to the end-user with
respect to the items within the folder and the folder itself.
Read-Only permissions
Items within the folder:
Users that have been granted read-only permissions to a folder are only allowed to view
items in the folder. They do not have the ability to synchronize any modifications of
items to the server. This means that the user can attempt to add, delete or edit the items,
but all the modifications will be lost when the folder resynchronizes with the server, as
the server will deny all changes forcing the plug-in to delete any additions, or edits, and
retrieve the original (including items that were deleted).
The Folder:
Users that have been granted read-only permissions to a folder do not have the ability to
synchronize the deletion of the folder or the creation of sub-folders. If the user attempts
to delete the folder, the plug-in will retrieve the folder from the server during subsequent
synchronizations. Any sub-folders that the user attempted to create will be deleted. Users
are able to view the permissions set for the folder but will not be able to modify the ACL
for that folder.
Read/Write permissions
Items within the folder:
Users that have been granted read/write permissions have the ability to read, add, delete
and edit items within the folder. Any modification of the items within the folder will be
synchronized with the server and then propagated to all other users that have permissions
to the folder.
The folder:
Identical to the read-only permission level, users that have been granted read/write
permissions to a folder do not have the ability to synchronize the deletion of the folder or
the creation of sub-folders. If the user attempts to delete the folder, the plug-in will
retrieve the folder from the server during subsequent synchronizations. Any sub-folders
that the user attempted to create will be deleted. Users are able to view the permissions
set for the folder but will not be able to modify the ACL for that folder.
Read/Write/Admin permissions
Items within the folder:
Users that have been granted read/write/admin permissions have the same capabilities as
those with read/write permissions.
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The folder:
Users that have been granted read/write/admin privileges have the ability to create and
delete any sub-folders (unless they don’t have read/write/admin privileges of the subfolder they are attempting to delete), and the folder itself (only if they also have
read/write/admin permissions to the parent folder). In addition to the ability to view ACL
information for the folder, the user has the ability to make modifications to the ACL.
NOTE: Viewing of items marked “Private” requires Read/Write/Admin permissions.
If a user has administrative privileges on the Net Integrator itself, he/she will have
read/write/admin permissions to all ExchangeIt! folders, whether or not they have
been shared to that user.

Synchronization
The ExchangeIt! server and the Outlook plug-in work together to synchronize data
between Outlook and the server. Unlike some other groupware/collaboration tools, the
data is not accessed directly from the server. Instead, when the user edits, creates, deletes,
or any way modifies the folders or folder contents, they are working with the data that is
locally resident. This implies that at all times, there are at least two copies of the item
(one locally, one on the server, and possible one or more to copies in other users’
Outlooks) unless the item has not been synchronized yet. Using this approach has several
benefits: The server has a copy that can now be automatically backed up by the Net
Integrator; users are able to see and modify items off-line.
Because of the design, there are several important things to realize and keep in mind.
a. Sharing of data is a two step process –
1) Modifications to the folders and their contents first need to be
synchronized between the server and the user that made the
modification.
2) The modification is synchronized between the server and the other
users to whom the folder is shared with.
b. Because the folder(s) and its contents are actually locally resident in
Outlook and the server, modifications, copying and moving items is
actually a “deletion” of the previous item(s) / folder(s), then the “creation”
of the new item(s) / folder(s).
c. If a user’s permissions to see a folder is removed, this is treated as a delete
by Outlook plug-in.

User Licenses
All licenses for ExchangeIt! are controlled on the ExchangeIt! server itself. Licenses are
allocated per user. Each user that is licensed is allowed access the ExchangeIt! server
from up to three simultaneous IP addresses. The IP addresses are tracked, aged, and
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obsoleted automatically by the server. This allows each user the capability to
simultaneously log in from different workstations, or to migrate from workstation to
workstation. Thus remote users have the ability to work remotely on their laptop, yet still
access the ExchangeIt! features when they use a desktop at the office.
The licenses can be assigned in two different ways. Users can be assigned a static
ExchangeIt! license or have their license drawn from a pool of available dynamic
licenses.
When users are assigned a license statically, their usernames will automatically appear in
the ACL. Additionally, their license will not be redistributed to another user. Static
license assignment and re-assignment must be done by the Net Integrator administrator
using the Web Configuration.
If the user is to use a dynamic license, the user will only appear in the ACL after having
recently connected to the ExchangeIt! server. Thus, if you have more users than you have
licenses, it is still possible to utilize ExchangeIt!, but you must manually track who’s
accessing ExchangeIt!, otherwise, users may at some point not be able to access and
synchronize anymore because not enough licenses are available.
It is recommended that the licenses be allocated statically as this will avoid confusion
should there be more users than there are licenses available, and it will also avoid
confusion in the ACL when user names don’t appear and disappear.

Sharing of your Personal Folders
All folders originating from a user’s message store will automatically be shared and
synchronized to the server with read/write/admin privileges to the user themselves. This
allows for the user to migrate to different workstations and have full access to their
Personal Folder contents (except mail). If the user wishes to share the contents to other
users, they must explicitly do so by modifying the ACL (by right-clicking on the folder
and selecting the ExchangeIt! tab). Remember that ALL of the folder’s contents are
shared (except mail), so make sure there aren’t items in there you do not wish to share
prior to setting the ACL.
It is possible to create sub-folders and share the sub-folders without sharing the contents
of the parent folder. For example, it is possible to create a sub-folder within “Contacts”
called “shared.” In addition to having contacts within the parent “Contacts” folder, you
can have contacts also in the “shared” folder. You can choose to share the “shared”
folder and not share the contents of the “Contacts” folder. Other users will see that
“shared” has a parent folder called “Contacts,” but they will not have the ability to look at
the ACL or see the contacts contained within it.

601-0003-07

Page 26

Version 1.0

Team Folders
Team and Public Folders
With the integration of ExchangeIt! into the core of the Net Integrator, users are able to
take advantage of Net Integrator’s team accounts.
Team folders work like any other folder – the only difference is that the team members
are automatically granted full read/write/admin privileges to the team folders. Using team
folders is one way for team members to work collaboratively by creating sub-folders
containing tasks, notes, or any of the other shareable content without having to have
someone designated as “hosting” the team’s data. The team folders will by synchronized
to each of the team members utilizing ExchangeIt!.
It is also possible to create sub-folders for a team that you can share to other users or
teams. This is useful for allowing other teams or users access to certain contents without
allowing them access to everything. For example, you can create a team on the Net
Integrator called “facilities” with only a few members on that team. Create a calendar
sub-folder called to “facilities” called “main boardroom” with read-only permissions
granted to everyone. This allows you to have members of the team “facilities” administer
the bookings for the “main boardroom.” Thus everybody will have the ability to see when
the “main boardroom” is in use, while only members of “facility will be able to modify.”
Of course this is just one specific example, you can setup the permissions and teams in a
multitude of ways to handle proper administration and access to company resources.
Teams and the ACL
The concept of teams can also help to facilitate sharing of folders and the setting of
permissions. In the ACL, all teams will appear. You can set the ACL permissions any
combination of users and teams. Setting the permission level for a team implies that
everyone that is a member of that team is granted that permission level. If a particular
folder is shared to users and/or multiple teams, the recipient user gains the highest
permission level combination.
For example – if there is a team with everyone in the company called “everyone,” and
another team called “finance,” you can choose to share your contacts at read-only
permission level to “everyone” AND share it with read/write privileges to “finance.” So
even though members of the “finance” are also members of “everyone,” they will have
read/write permissions while everybody else has read-only permissions.

Public Folders
If a user has folders that they have shared to them – a new parent folder will appear called
“Public Folders.” Beneath this “Public Folders” will appear with one or more sub-folders
listed by the source. The source name is either the Team name or the username of the
user from whom the folder is being shared.
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Creating folders directly under Public Folders
The only way to create folders directly beneath “Public Folders” is:
a. another user shares one or more of their personal folder(s) with you
b. being a member of a team
c. another team has shared one or more folders with you
Although it may appear that users are able to create folders that are directly parented by
“Public Folders,” this is in fact not possible. When the plug-in resynchronizes with the
ExchangeIt! server, all “created” folders and any content will be removed (read deleted)
by the plug-in.
Deleting folders directly under Public Folders
Your ability to delete folders is dictated by the permissions you have been granted by the
ACL. Because no one has permissions at the “Public Folders” level (by design), you will
not be able to completely remove folders directly parented by “Public Folders”.
Remember that to delete the folder itself you need to have read/write/admin privileges to
the folder as well as to the parent.
If the user deletes a folder for which they have read-only permissions, the folder and all
of its contents will be restored when the user is resynchronized.
If the user deletes a folder for which they have read/write permissions, the folder will be
restored, but all the contents will be deleted when the user is resynchronized.
If the user deletes a folder for which they have read/write/admin permissions, the folder
will be restored, but all the contents as well as any sub-folders for which they have
read/write/admin privileges will be deleted.
Notice that these permission levels will be obeyed by all subfolders as well. Thus a
deletion will force a deletion of all contents and sub-folders to maximum extent possible
given the permissions of the user deleting.

Uninstalling
Exiting Outlook and then running the uninstall from the “Add/Remove programs” of
Windows will uninstall the ExchangeIt! plug-in.
Because of the design of ExchangeIt! to work locally with Outlook, all the Public Folders
that have been shared with the user will still be present in Outlook. The user will need to
open Outlook and manually delete the Public Folders to get rid of all the content.
For a “clean” re-install of the plug-in, the following steps should be taken:
1)
2)
3)
4)

Exit Outlook
Uninstall the plug-in
Open Outlook and delete “Public Folders”
Exit Outlook
5) Re-install the plug-in
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Calendars, Free/Busy, and Meeting Requests
Outlook is mostly capable of using standard formats for the updating and requesting of
other Outlook users’ free/busy information and booking of meetings. This allows people
to book meetings with other users (or resources), and instantly see when people (or
resources) are available.
ExchangeIt! extends this capability by providing a locally hosted free/busy server.
Without the locally hosted free/busy server, users wishing to utilize this feature would
have to send their information to one of the Internet hosted servers. Using an Internet
hosted server can bring a host of potential problems.
The plug-in utilizes Outlook’s native capability to talk to a free/busy server by
automatically filling in the appropriate address tag in the Free/Busy options during
installation.
ExchangeIt! and the Outlook plug-in utilize standard protocol and standard formats for
the transport of data and communications between Outlook and the ExchangeIt! server.
Because of these standard implementations, there are a few things that the system
administrator and the users need to know and understand.
Most of the functionality utilized is native to Outlook. Unfortunately, Outlook doesn’t
handle some of the standards very well.
Meeting Requests
In particular, Outlook has problems with the receiving of meeting requests from Internet
standard “iCalendar” meeting requests. Note that these are issues with Microsoft
Outlook and not due to the installation of the ExchangeIt! plugin. The presence of the
plug-in does not alter this behaviour. These are some known issues with Outlook (see
references below for more information).
The work-arounds that we recommend for the sending of meeting requests (so they can
be received properly) are as follows:
A) If everybody is using Windows and Microsoft Outlook:
1)
From Outlook’s Tools Menu: Preferences Tab-> Calendar Options
Disable the “when sending meeting requests over the Internet, use the
icalendar format.
2)
From Outlook’s Tools Menu: Mail Format Tab
“Compose in this message format:” should be selected to “Rich Text”
3)
From Outlook’s Tools Menu: Mail Format Tab -> Internet Format
“When sending Outlook Rich Text messages to Internet recipients, use
this format:” should be selected to “Send using Outlook Rich Text format”
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B) If there is a mixture of Outlook 2000 and Outlook 2002 and other clients, there will
be some incompatibilities. To reduce these incompatibilities we suggest the following
when you are creating the meeting request:
1)
Do not enable the “reminder”.
2)
i) In the “To” box, type the recipient’s e-mail address, and then doubleclick the e-mail address.
ii) In the E-mail Properties dialog box, in the Internet format box, change
the option from “Let Outlook decide the best sending format” to “Send
Plain Text only.”

http://support.microsoft.com/default.aspx?scid=kb;en-us;218376
http://support.microsoft.com/default.aspx?scid=kb;en-us;284392
http://support.microsoft.com/default.aspx?scid=kb;en-us;307313
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